#community-help

Typesense Docker Service Setup Issue Resolved

TLDR Jeff raised an issue regarding unexpected behavior while setting up Typesense Docker service and a possible bug in release 0.23.1. Kishore Nallan confirmed the issue, mentioning it is fixed in the latest release candidates and will be in future releases.

Powered by Struct AI
Aug 12, 2022 (17 months ago)
Jeff
Photo of md5-7b8d7dc126a8f3a045be2429b931f7bf
Jeff
09:45 PM
Hi All, We were having issues setting up a Typesense docker service as part of our local development automation. In production, we're using Typesense Cloud but we run Typesense in a docker container for local development support.

The bug is apparent when we use the latest release 0.23.1.

For development, we have a setup script that runs a series of command to provision all Typesense collections and then index documents for each collection from the seeded development data. The script and commands work as expected when executed on the host machine against the docker Typesense instance but have strange behaviour when the same script is run as part of the associated API's Docker command. i.e. the script is called in the API Dockerfile command before executing the actual API server process,

All collections are provisioned properly and the command feedback for each index command looks correct. When we check the actual content of the collections however, they all contain the same documents. i.e. One collection (the last command to run) contains the correct documents and data but the other collections all contain the exact same documents instead of the correct documents for each collection.

When I run the Typesense docker instance with the most recent 0.24.0.rc29 version, the problem goes away. Normally, with the problem gone, I would stop there but this version is obviously a release candidate and I can't find any completed issues or commit that seem to address the bug I was experiencing.

Are there any changes between 0.23.1 and 0.24.0.rc29 that might be what solved this bug for me? Will this fix/change still be present in the next latest release?
Aug 13, 2022 (16 months ago)
Kishore Nallan
Photo of md5-4e872368b2b2668460205b409e95c2ea
Kishore Nallan
02:32 AM
Yes we noticed this issue when you create collections in a very short burst on local env. That has been fixed in latest RCs and will be part of future releases.